The ADB 2012 Revit Add-on vs 3.1.0.
Introduction
The ADB Revit Add-on introduces functionality to Revit similar to that provided by the ADB AutoCAD Interface i.e. room loading from an ADB project database, comparison checking of model contents and project database and updating ADB room data sheets from the model. Standard Revit provides all the functionality for the production of C-Sheets plus the advantage of automatic synchronisation with the model and the removal of the need to regenerate when changes are made.

Version 3 of the ADB Revit Add-on supports Revit 2009/2010/2011/2012 and 2013 in both 32 bit and 64 bit versions. For 64 bit versions the Revit add-on is a native 64 bit application. This requires ADB to be configured for use with SQL Server project databases. SQL Server provides significantly improved multiuser performance and data security. Please see the Appendix for SQL Server installation considerations.
The ADB 2012 Revit Add-On is accessed via the Revit Add-Ins Ribbon strip.
For Revit 2010/11 and 12 the ADB menu is under the Revit Add-ins menu.
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For Revit 2013 ADB has its own menu.
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ADB Revit Add-on 3.1.0 has functionality to import ADB functional, environmental and design character data as Room parameters. If these parameters are updated in Revit they can be written back to the ADB database. If you add any or all of the Parameters in the table below when you use the ADB Set Room Parameters option the Parameters will be set from the ADB project database. ADB Revit Add-on 3.1.0 has support for both the standard and new engineering data formats.
Installation

If you have any previous version of the ADB Revit Add-on installed please uninstall using Add/Remove Programs.
Download and double click ADBRVTSetup3.1.0.msi file install the ADB Revit Add-on.

After installation a new application ADB Revit Add-on Configuration will be added to All Programs menu (this is different to previous versions which modified the standard ADB Configuration facility). For 32 bit versions of Windows only the 32 bit versions of Revit can be installed. For 64 bit versions of Windows both Revit 2009 32 and 64 bit can be installed, while for Revit 2010/2011/2012 and 2013 the 64bit will be installed automatically. 
32 bit Windows versions
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To configure select the required version of Revit, locate the Revit.exe file and clicking [image: image4.png]Corfigurs



 displays:-
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Select Yes and you should receive a message that the configuration has completed successfully.
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64 bit Windows versions with 64 bit Revit Only
64 bit versions of Revit require ADB to run with SQL Server databases as Microsoft do not provide 64bit drivers for MS Access. Before configuring 64 bit versions of Revit you must configure the ADB Explorer for use with SQL Server as described in the Appendix below. You are advised to use the ADB Explorer to create a test ADB SQL Server project and familiarise yourself with the procedure of saving MS Access projects to SQL Server and vice-versa. Any existing ADB MS Access projects will need to be saved to SQL Server. For assistance on installing and configuring SQL Server you should consult your IT specialist.
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To configure select the required version of Revit, locate the Revit.exe file and clicking [image: image8.png]Corfigurs



 displays:-
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You should then receive the message
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Sample Data (all versions)
An ADB project and an associated Revit family library is available from www.spaceforhealth.nhs.uk  for evaluation/training purposes.

The full ADB 20.4v2 and ADB 1203 component library (approximately 3000 items) has been exported as Revit families and is available to current ADB licence holders on request. All ADB 2009a components are in 3D and where 3D graphics are not available in ADB204v2 2D representations are used instead. Note these families have been created from AutoCAD 3D models.
Setting up the ADB Revit Add-on
1. Create an new Revit project and  use Menu Settings>Project Parameters (Manage>Project Parameters Revit 2010/2011/2012) to add the parameters:-
a. Name:ADBLoadRoom  Type:Yes/No Categories:Rooms 
b. Name:ADBEquipmentMismatch  Type:Yes/No Categories:Rooms
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2. Create and directory ADB under C:\Documents and Settings\All Users\Application Data\Autodesk\RAC 20xx\Metric Library (or C:\ProgramData\Autodesk\RAC 20xx\Metric Library for Windows 7) and unzip and Copy the ADB families to that location. You can use a different location and specify this in the ADB Revit Add-on Options menu. 

3. Loading ADB Families

If you are just using the sample data you can load all the families as described below as this will speed the room loading process. If you are using the Full Library it is suggested that you allow the ADB Revit Add-on to load families on demand so that the model can be kept as small as possible.
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Revit 2010/2011/2012/2013
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3. For each Level on which ADB components are to be inserted set the View Range so that Primary Range Top and Cut Plane offsets to the room height. e.g. select the Floor>Level >Properties.
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If this is not done some components will not be visible.

Using the ADB Revit Add-on.
1. Run the ADB Explorer and register the sample project. Please note ADB project data must be in the form of room ordered departments.

2. Run Revit and click ADB Login on the Revit toolbar (or on the Add-ins ribbon strip for Revit 2010/2011/2012) and select the sample project
Revit 2009
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Revit 2010/2011/2012
[image: image19.png]Autodesk Revit Architecture 201

== e e
- EpT—p—— = o

B Esaeommn E = = 3
= [ tnsert Room [ Check Room

Stamsl | 108 1aon | O owe e cepp | G

Tooks 8 Load Component | & Check Room Schedule

Extemal Actty Database





Revit 2013
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Create a simple building with rooms. (all versions)
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Assign a Revit Room to each room
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Assign ADB Room parameters to each Room by selecting ADB>Tool>Set Room Parameters…
Revit 2009
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Revit 2010/2011/2012/2013
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Note to select the room by select hover the mouse over the room until the cross-hairs become visible and then pick one the lines (if necessary use the Tab key to cycle through selectable items). 
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Revit 2009
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Revit 2010/2011/20122013
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Examine the properties of the Rooms to see the additional ADB properties.

Room Loading
Individual Rooms can loaded or all Rooms loaded for a Department. To load an individual Room select the ADB>Edit>Insert Rooms by Selection.

Revit 2009
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Revit 2010/2011/2012
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Revit 2013
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Click insert, wait for the Room to load and Close.
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To load the Rooms for the Department select ADB>Edit>Insert Rooms for Department… and enter the Department code.

Revit 2009
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Revit 2010/2011/2012/2013
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Please Note: when ADB families are loaded into a Revit model for first time there will be a delay while this loading takes place. The ADB Revit Add-on software scans and keeps a record of all loaded families so the room loading process will be significantly faster once the families have been loaded.
Having loaded the rooms, arrange the items as required to suit the room shape.
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The room components are loaded as a Revit Group to assist where rooms overlap.

View the room in 3D.
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Checking the Revit Model against the ADB Project Database
The Department Room Schedule can be checked against the database by selecting the ADB>Database>Check Room Schedule menu option.
Revit  2009
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Revit 2010/2011/2012
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Revit 2013
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The grid contents can be exported to Excel.

The Contents of specified Rooms for a Department can be checked against the database by selecting ADB>Database>Check Department Rooms (Check Department).

[image: image48.png]Check Department Rooms

Seleot the e
Sampe Deparment =

Use a window to select al the Rooms and content t check.
Ensure al ftems are selected, ary ftoms selected a
which are ot n the Depatment wil automaticaly be ignored.  ——]

[Log
[Chesking.

[Foom L0226 0K
oo 0206 0K
[Floom:T0505 Mismatch
[RoomX0112 0K
Check Completel





The results of the Equipment Check can be displayed graphically by creating a colour scheme. Right click on the floor plan away from the building and click the button to change a colour scheme.
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Click the new icon under Schemes change the description and title select ADBEquipment mismatch under Colour and specify colours for No and Yes
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The results are shown below.
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The contents of individual Rooms can be checked against the database using the ADB>Check Room… menu (or Check Room Revit 2010/2011/2013) option.
[image: image52.png]1. Pk the Roomto check by selcing th cosshais.. | %

[RoomDetals ———————————————
Code: [T0505 Number. [G.03

Depatment: [SAMPLE

2 Use awindow o select althe items n the Room.
Ensure al tems are selected, any tems selected a
which are nat in the Fioom il automaticaly be ignored.

BASTH
Calian
IS0t
Dis0i3
Dista0
DISe%
ORI

Code ModelQy | Daabase Oy 3

e





Differences between the Model and ADB Database are highlighted.
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Updating the ADB Project Database from the Revit Model

The ADB database can be updated from the drawing by selecting ADB>File>Save Room for Department (or Save Department ribbon strip).
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Individual Rooms can be updated by selecting ADB>File>Save Room (Save Room Revit 2010/2011/2012/2013)
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Equipment Scheduling by Room
Revit 2009
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Revit 2010/2011/2012/2013
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Creating C-Sheets Revit 2010/2011/2012
(*New - see automated C-Sheet creation for Revit 2013)

Create a callout for the room and add elevations for each wall and rename including the code or room number
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Modify the height of the elevation as required
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Create a schedule of components for a room
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Rename as required
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Select OK to display

[image: image70.png]Schedule Properties ()

Edt... Delete Edt. Delete
(Mhtile Categories 7] Move Up. Move Down





Select the fields ADBCode, ADBDescription, ADBGroup, Count from Multiple Categories and the Room: Name and/or Room: Number from Room
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Select the Filter tab and specify the Room Number or Code.
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Select Sorting/Grouping, specify ADBCode as Sort by: and uncheck Itemize every instance.  
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Select Formatting
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Hide the Room: Name and/or Room Number field if required.
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Open a new sheet and add the plan, elevations and schedule
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Adding Tags

Load the ADB Room Tag by File>Load from Library>Load Family (Insert>Load Family for Revit 2010/2011) and select the ADB Room Tag from the ADB family directory. Select the room plan or elevation to tag, select the items to tag followed by Tag All Not Tagged on the drafting menu. Arrange the tags as required.
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Revit 2009
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Revit 2010/2011/2012
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Shared Parameters File

To load the ADB shared parameters file
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Browse and select ADB Revit Shared Parameters V3.txt
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ADB Room Attributes available as Revit Parameters
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Note: if you add or update these parameters for a room which has already been loaded with equipment you will need to manually uncheck the ADBLoadRoom flag
Revit ADB Parameters

	General and Design Character Data
	

	Revit ADB Parameter Name
	Revit Data Type

	ADBRoomDescription
	TEXT

	ADBRoomClass
	TEXT

	ADBRoomPersonnel
	TEXT

	ADBPlanningRelationships
	TEXT

	ADBSpaceNotes
	TEXT

	ADBFlooring
	TEXT

	ADBCeilings
	TEXT

	ADBGlazing
	TEXT

	ADBDesignNotes
	TEXT


	Engineering data – original format
	

	Revit ADB Parameter Name
	Revit Data Type

	ADBWinterTemperature
	Number

	ADBSummerTemperature
	Number

	ADBMechanicalVentilationSupply
	Number

	ADBMechanicalVentilationExtract
	Number

	ADBDustSpotEfficiency
	Number

	ADBRelativeHumidity
	Number

	ADBArrestance
	Number

	ADBHVAC
	Text

	ADBTemperatureNotes
	Text

	ADBMechanicalVentilationNotes
	Text

	ADBFiltrationHumidityNotes
	Text

	ADBRelativePressure
	Text

	ADBServiceIllumination
	Number

	ADBServiceIlluminationNight
	Number

	ADBLocalIllumination
	Number

	ADBColourRendering
	Yes/No

	ADBStandbyLightingGrade
	Text

	ADBIllumination
	Text

	ADBStandbyLightingGradeNotes
	Text

	ADBServiceIlluminationNotes
	Text

	ADBServiceIlluminationNightNotes
	Text

	ADBColourRenderingNotes
	Text

	ADBHotSurfaceTemperature
	Number

	ADBHotWaterTemperature
	Number

	ADBPrecautions
	Text

	ADBSafetyNotes
	Text

	ADBAcceptableSoundLevel
	Number

	ADBSpeechPrivacy
	Yes/No

	ADBQualityNotTolerated
	Text

	ADBPrivacyFactor
	Number

	ADBMechanicalServices
	Number

	ADBIntrusiveNoise
	Number

	ADBAcoustics
	Text

	ADBNoiseNotes
	Text

	ADBFireProtection
	Text

	ADBEnclosure
	Text

	ADBAutomaticDetection
	Text

	ADBGlazing
	Text

	ADBHatch
	Text

	ADBWindows
	Text

	ADBDesignNotes
	Text


	Engineering Data – new format
	

	Revit ADB Parameter Name
	Revit Data Type

	ADB2AirChanges
	TEXT

	ADB2AutoDetection
	TEXT

	ADB2AutoDetectionNotes
	TEXT

	ADB2ClinicalRisk
	TEXT

	ADB2ClinicalRiskNotes
	TEXT

	ADB2ColdWaterDischargeTemperature
	TEXT

	ADB2ColdWaterDischargeTemperatureNotes
	TEXT

	ADB2ColourRenderingCharacteristics
	TEXT

	ADB2ColourRenderingCharacteristicsNotes
	TEXT

	ADB2ColourRenderingRequired
	TEXT

	ADB2ColourRenderingRequiredNotes
	TEXT

	ADB2DaytimeGeneralServiceIlluminance
	TEXT

	ADB2DaytimeGeneralServiceIlluminanceNotes
	TEXT

	ADB2DaytimeSpecificServiceIlluminanceNotes
	TEXT

	ADB2DomesticHotWaterDischargeTemperature
	TEXT

	ADB2DomesticHotWaterDischargeTemperatureNotes
	TEXT

	ADB2EmergencyEscapeRouteLighting
	TEXT

	ADB2EmergencyEscapeRouteLightingNotes
	TEXT

	ADB2FinalFilterClass
	TEXT

	ADB2FinalFilterClassNotes
	TEXT

	ADB2FireNotes
	TEXT

	ADB2HeatingDesignTemp
	TEXT

	ADB2HeatingDesignTempNotes
	TEXT

	ADB2HVACNotes
	TEXT

	ADB2LightingNotes
	TEXT

	ADB2LocalTaskIlluminance
	TEXT

	ADB2LocalTaskIlluminanceNotes
	TEXT

	ADB2MaxSurfaceTemperature
	TEXT

	ADB2MaxSurfaceTemperatureNotes
	TEXT

	ADB2NighttimeGeneralServiceIlluminance
	TEXT

	ADB2NighttimeGeneralServiceIlluminanceNotes
	TEXT

	ADB2NighttimeSpecificServiceIlluminance
	TEXT

	ADB2NighttimeSpecificServiceIlluminanceNotes
	TEXT

	ADB2NoiseIntrusionDay
	TEXT

	ADB2NoiseIntrusionFNight
	TEXT

	ADB2NoiseIntrusionNight
	TEXT

	ADB2NoiseLevelNotes
	TEXT

	ADB2NoiseMandE
	TEXT

	ADB2NoiseMandENotes
	TEXT

	ADB2NoiseNotes
	TEXT

	ADB2NoiseSensitivity
	TEXT

	ADB2NonClinicalRisk
	TEXT

	ADB2NonClinicalRiskNotes
	TEXT

	ADB2PermissibleSpaceTemp
	TEXT

	ADB2PermissibleSpaceTempNotes
	TEXT

	ADB2RelativeHumidityRange
	TEXT

	ADB2RelativeHumidityRangeNotes
	TEXT

	ADB2RelativePressure
	TEXT

	ADB2RelativePressureNotes
	TEXT

	ADB2RiskNotes
	TEXT

	ADB2SafetyNotes
	TEXT

	ADB2SoundInsulationGeneration
	TEXT

	ADB2SoundInsulationNotes
	TEXT

	ADB2SoundInsulationPrivacy
	TEXT

	ADB2SoundInsulationRating
	TEXT

	ADB2SoundInsulationRatingNotes
	TEXT

	ADB2StandbyLightingGradeGeneral
	TEXT

	ADB2StandbyLightingGradeGeneralNotes
	TEXT

	ADB2StandbyLightingGradeLocal
	TEXT

	ADB2StandbyLightingGradeLocalNotes
	TEXT

	ADB2TypeOfControl
	TEXT

	ADB2TypeOfControlNotes
	TEXT

	ADB2UnifiedGlareRatingLimit
	TEXT

	ADB2UnifiedGlareRatingLimitNotes
	TEXT

	ADB2VentType
	TEXT


	ADB Component Shared Parameters
	

	Revit ADB Parameter Name
	Revit Data Type

	ADBCode
	TEXT

	ADBDescription
	TEXT

	ADBGroup
	TEXT

	ADBWidth
	LENGTH

	ADBDepth
	LENGTH

	ADBHeight
	LENGTH

	ADBParent
	TEXT

	ADBFixingParameter
	LENGTH

	ADBMountingHeight
	LENGTH


Creating an ADB Revit family
Firstly ensure that the ADB Revit Shared Parameters File v3 is loaded.

First use ADB to create a new Component and assign an ADB class and group e.g. WKT900 with group1

You can create the ADB family by copying an existing family and renaming the rfa file to WKT900.rfa. Edit the Family Types to change the code, description and group to match those assigned in ADB.

Alternatively you can create the family from scratch as described below.

The screens shown are from Revit 2010 but the process is the same for Revit 2009/2011/2012
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*New Functionality for ADB 2012

*Families with Parametric Fixing Heights
Firstly ensure the shared parameters file ADB Shared Parameters File V3 is loaded as described above. New component parameters are available as shown below.
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To add the new parameters to an existing family open the family and select [image: image98.png]) Add Family Parameters



. This will add the parameters ADBFixingParameter, ADBFixingHeight, ADBDepth, ADBHeight and ADBWidth to the familty 
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Use standard Revit functionality to parameterise the fixing height using the ADBFixingHeightParameter  and add range of family types e.g. OUT010 Fix 500, OUT010 Fix 900 etc. Always ensure there is a family type OUT010 with a fixing height of 0.0.
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If required add other parameters ADBWidth, ADBHeight and ADBDepth.

When loaded into the model these families will appear in the project browser as shown below.
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When a room is saved another parameter ADBMountingHeight is populated from one of two sources:-

1. Where the items have an ADBFixingHeightParameter this value is transferred to the parameter ADBMountingHeight;
2. Where items have do not have an ADBFixingParameter the family offset value is copied to ADBMountingHeight;
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This allows a mounting height schedule to be generated for a room as follows.  
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Name the schedule
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Add the fields ADBCode, ADBDescription, ADBGroup and ADBMountingHeight from Multiple Categories
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and Room: Name and/or Room: Number from Room
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Specify the Room Code or Number as a filter
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Specify Sorting by ADBCode and ADBMountingHeight
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Hide the Room: Name and Room: Number fields
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Select OK to display the Fixing Height Schedule
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*Add Parameters to all Families
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This option will add the parameters ADBFixingParameter, ADBFixingHeight, ADBDepth, ADBHeight and ADBWidth to all the families in the directories specified under the Options. Please note selecting this option will save the modified families in the current version of Revit and will not be compatible with earlier versions.
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Families will need to be reloaded into the Revit model for these parameters to be visible.

*Missing Components
When a Revit model includes Rooms with ADB Components which do not exist in the currently selected ADB project these will be highlighted as follows when the Room is “Checked” or “Saved” 

[image: image114.png]1. Fick the Room o check by selectng the cioss hais

Room Detalls:
Code: o226 Number: G.02

Department.  SAMPLE.

2 Use a window o select althe items n the oo,

Ensure all tems ate selected, any ftems selected a
which 1 ntin the Foom il aomatiealsbe nored
[ which e ot the ADB proect datbase s maked ] |

=

Code Model Oty Database Oy
BASO0S"
BASTON
AL
CaLon7
Loz
Calng
CHAT7
CHADE3





[image: image115.png]Save Room to Project ==

1. Pick the Fioom to save by slecting the cross hais

Room Detalls:
Code: 0226 Number:  G.02

Depatiment.  SAMPLE
[[] Load Floom (s mst be unchecked)

Ensure al tems are selected, any tems selected
which are nat in the Fioom il automaticaly be ignored.
fitems which ate ot in the ADB project database are marked *

Log

HOOU22  X81.46 Y:1816.03 2:1400.00 Rotation 85.91  »
CALOT2 at X:4380.00 Y:1400.00 Z:1100.00
Fotation270.00

WAS107 at X:2630.00 Y:46.50 Z:597.50 Rotation:180.00
DIS030 at X:2820.00Y:100.00 7:1090.00 Rotation:180.00
(CALOD3 at X 780,00 Y-0.00 Z:1200.00 Rotation:180,00
DISDT1 at X:2530.00 Y:100.00 7:1090.00 Rotation:180.00
DISO13 at X:2130.00 Y:0.00 :1090.00 Rotation-180.00
'BASD05" at X-1915.00 Y:5000.00 2:0.00 Rotation 0.00
Update Complete!

2 Use awindow o select althe items n the oo, @

Soe | Lo |





*Automated C-Sheets (Revit 2013 only)
With ADB 2012 and Revit 2013 C-Sheets (elevations, 3D view and schedules on a single drawing sheet) can be created automatically.
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Selecting “Generate C-Sheets” displays the form below. Adjust the settings as required, select one of more rooms and click Generate. This will  display the form below.
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The following message will appear when generation is complete.
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Open the newly generated sheet, hide any unwanted walls/floors in the 3D view and adjust the schedule columns to obtain the display below. 
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Appendix

SQL Server Installation

The following is reproduced from the ADB 2012 Installation and configuration notes.

Activity DataBase can be used with SQL Server versions 2000, 2005 and 2008 including the express versions as well as MS Access databases.  The user interface is virtually identical for both database types.  SQL Server is required for 64 bit versions of AutoCAD.

ADB 2012 Projects are now created in batches by the system administrator which has the following advantages:

· The server does not have to be configured to allow remote attachment of databases by users.

· The backup process is simplified for system administrators as database creation is under their control.

· For users the process of project creation appears very similar to MS Access the only difference is that the database names are predefined while the user can assign any project code they wish.

· When all available projects have been assigned the user receives a message that they should ask the system administrator to create another batch of projects.

Two scripts in the SQL Scripts directory on the CD are provided for the purpose initial system setup and batch database creation. The process is as follows:

· Copy the files from the SQL Scripts directory on the CD to a suitable folder on the Server where SQL Server is installed.

· Run the SQL Server Management Studio (SQL 2005/8) or Enterprise Manager SQL 2000. Open the script AttachControllerDatabase.sql change the path to the location where you copied Master2000.MDF and run the script. You should then have a database MASTER2000 in the list of databases. This script only needs to be run once.

Important: Users who are upgrading from ADB 2010 and 11 should delete any existing MASTER2000 database before running the AttachControllerDatabase.sql script.
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· Open the script CreateADBDatabases.sql. Edit the source path change the path to the location where you copied ADBTemplate_20_82.MDF and change the target path to where you wish the ADB project databases to be created. By default the script creates 5 databases each time it is run. Change this as required. On running the script you should see new databases beginning with ADB added to the list.
(Note the script assumes the paths do not contain spaces)
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Having installed both SQL Server and Activity DataBase, select Modify an Option on the task bar.
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Having entered the server details select Test Connection. This must display a message similar to that below.
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Creating a new SQL Server project is similar to creating a new MS Access project, except that SQL Server should be specified as the Project Type.
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You should receive a message similar to that below.
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To register a SQL Server project created by another user, enter the Server name, Username and Password and click Fetch Database List.  Select a database from the list and click Register.
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All other operations are identical with the MS Access version.

	


Special SQL Server 2005/2008 considerations

ADB requires either the full version of SQL Server 2005 or for small installations Microsoft SQL Server Express 2005. SQL Server Express is a free download from Microsoft.
Installing SQL Server 2005/2008 Express Edition. 

There are two parts to the download:
1. The SQL Server SQLEXPR.EXE for 32 and 64 bit servers)

2. The SQL Management Studio SQLServer2005_SSMSEE.msi (for 32 bit servers)  and SQLServer2005_SSMSEE_x64.msi (for 64 bit servers)
Note 64 bit Revit 64 bit does not require 64 bit SQL Server.

Install SQLEXPR.EXE on the server for standalone working on the local machine.
ADB requires SQL Server Authentication which is not the default. During the installation process when the Authentication Mode for is displayed you should select Mixed Mode (Windows Authentication and SQL Server Administration)
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Specify a password if required.

For other form accept the defaults.

Install the version of the SQL Server Management Studio Express for the particular machine type.

If you wish to change/remove the password settings run the SQL Server Management Studio Express. (Note the server name will be different or you can use .\SQLEXPRESS if you are running on a standalone version)
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Right click on Login sa and display the Properties.
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Ensure password policy is unchecked.

Configuring SQL Server 2005/2008 Editions. 

Trace flags 1802 to turn off additional security should the database become detached.

The trace flags can be set automatically by adding ;-T1802 to the SQL Server startup parameters as shown using the SQL Server Configuration Manager
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IMPORTANT ensure that the Windows group Everyone has Sharing Permissions set to full control of the directory where the ADB project databases are located.
Version 1.0 Peter Bishop 27/06/2008
Version 1.1 Peter Bishop 20/08/2008 Updated for Revit 2009
Version 1.1.1 Peter Bishop 10/01/2009 Release version.
Version 1.2 Peter Bishop 30/07/2009 Additional functionality plus Revit 2010.
Version 2.0 Peter Bishop 1/03/2010 ADB 2010 version, full 64 bit support.

Version 2.0.1 Peter Bishop 27/5/2010 Revit 2011 support added

Version 2.0.5 Peter Bishop 7/3/2011 Minor fixes plus expiry date extended

Version 2.0.5A Peter Bishop 5/7/2011 Revit 2012 added

Version 2.0.9 Peter Bishop 2/1/2012 Support for phases minor plus expiry date extended

Version 3.0.0 Peter Bishop 30/3/2012 Additional functionality ADB 2012 version

Version 3.1.0 Peter Bishop 25/9/2012 ADB 2012 version, automated C-Sheets 
                       plus Revit 2013.
Please contact peter@integra.uk.net if you have any suggestions or queries.
