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Activity DataBase Graphics Library

The Activity DataBase AutoCAD interface is fully integrated into the AutoCAD user interface and adds a custom menu and toolbar to AutoCAD.  The interface uses Activity DataBase Explorer style forms and filters and allows more than one AutoCAD session to be run concurrently with Activity DataBase, with different projects.  To access the Activity DataBase Graphics library AutoCAD must have been configured for use with your version of AutoCAD (see section Maintenance Operations in the Activity DataBase 2012 Installation and Configuration Notes). Please note to use Activity DataBase with 64 bit versions of AutoCAD2010/11 and 12 requires SQL Server which must be installed and configured prior to using AutoCAD also described in the Activity DataBase Installation and Configuration Notes.
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 On running AutoCAD 2007/8/9 and AutoCAD 20010/11/12 in “Classic Mode”, the Activity DataBase AutoCAD menu and toolbar will be displayed. For AutoCAD 2012 32bit version and AutoCAD 2010/11 and 12 there is a “Ribbon” option. For AutoCAD 2010/11 and 12 in “Classic Mode” the appropriate VBA Enabler needs to installed which is available from www.autodesk.com
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Click the Activity DataBase Login button [image: image4.png]


 on the toolbar/ribbon, enter the username and password and select the project from the dropdown list.  This will display the full Activity DataBase AutoCAD toolbar and activate the menu.  Note, to change the project select the [image: image5.png]


 again.

Open the drawing on which you wish to work if this is not already displayed.
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N.B. The data described in the examples below is only indicative and will vary depending on the ADB reference project being used.
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As a guide a series of rooms e.g. 5000mm wide by 5000mm deep as shown above will accommodate the data created in the Tutorial project.

Automated Room Loading

To link Rooms on the drawing to the ADB project database a special polyline termed an enclosure is added for each room. Enclosures have extended data which define the Department and Room. The Department must be Room Ordered with Room Numbers assigned to each Room. To add enclosures select ADB>Enclosures>New
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on the ADB Ribbon. 
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Note click the [image: image13.png]


 button to browse the data.

Once the enclosure details have been defined, draw anti-clockwise round the room.  The first point should correspond to the base point of the room to be loaded from the database.  This would normally be the left-hand corner of the room when viewed from outside the room. Enclosures need not be rectangular or consist of orthogonal lines.
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Once created the Department and Room codes and Room Number will be placed in the enclosure.

Repeat this for all Rooms you wish to load. Note this does not have to be the complete department; for training purposes 3 or 4 rooms will suffice.  Once you have drawn all the enclosures you require, Use the ADB>Database>Check Department Room Schedule or click [image: image15.png]


on the Database ribbon to check that all the required Enclosures have been added to the drawing.  This will report Rooms in the database and not on the drawing, Rooms on the drawing and not in the database.
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To automatically load the Rooms for a Department, select the ADB>Insert> Department… 
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Click the record selector to highlight the row and click OK.

Alternatively click the Department button [image: image23.png]


 on the Activity DataBase toolbar and enter the code of the Department.
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The Rooms will then be populated from the database.

	[image: image25.png]AutoCAD 2010 - NOT FOR RESALE  Tutorial7 Loaded.dwg
Format Draw Moy
Render _Insert _Annotate  View  Manage  Output _ Express Took

= =
. | e B W Rt s
Oun B BR EEgd 200"

& = =

Insert Encsure | Database|  Views

Edititng enclosure. ..
Select objects: 1 found

select objects:

Hodity enclosure details:

Checking 1 selection set enmtities...

Command:







Each Room should be exploded and the equipment arranged as required.  For AutoCAD 2006, 7, 8, 9, 10, 11 and 12 Checking the AutoCAD Option Replace Z value with current elevation will ensure the Z co-ordinate of an item is preserved when Osnap is on.
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Having inserted the rooms explode them to reveal the assemblies and components and arrange the items to suit the room shape.
Items can also be added and deleted as required. For example, to add CHA005 to the Office/Meeting Room M0303 select the menu option ADB>Insert >Component…
	
[image: image27.png]In

Departent
- Endosures » Room

Dotsbase » pssembly

Toos >
Options >
bep >




The ADB Ribbon equivalent is
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Specify the view and add the component to the room.
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Alternatively if the component code is known select the ADBComponent toolbar button [image: image33.png]


 and specify the component code
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Adding Tags
In previous versions of ADB when a Room is inserted into a drawing the Room is an AutoCAD block displaying the codes of first level items (Assemblies or Components) as attributes. When the Room is exploded to re-arrange the items these attributes become attribute definitions and are no longer connected to the Component. 

A new option that allows tagging of items after the Room has been exploded has been added. These tags are attributes and are connected to the object. They can be moved rotated using standard AutoCAD commands. This method is now the default option as set by the Options>Top Level Attributes menu option. Un-checking this option reverts to the original behaviour. The ADB Ribbon equivalent is under Options.  
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To tag the items after exploding the Room/Assembly select the Tools>Add Tags and select the items to be tagged and Enter.
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The ADB Ribbon equivalent is.
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To Tabulate Tags

Once tagged if required if attributes can be tabulated as shown using the Tools>Arrange Tags menu option specify the. The attribute rotation can be set using Option>Set Attribute Font Rotation. Tags can be removed using the Tools>Remove Tags menu option and selecting the items from which the tags should be removed. The equivalent ADB ribbon items are shown below.
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PLEASE NOTE tags themselves are not used by scheduling but do affect if an item is considered to be in a Room. In the example below the item is taken to be in the Room as even though the icon is outside the enclosure the tag is inside. You need to ensure the tags do not overlap other enclosures.
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A similar facility is available for AutoCAD attribute definitions which can be useful for tabulating attributes on C-Sheet elevations.
 Checking Rooms contents against the database
This check can be performed for individual rooms or all rooms within a department.

For each Room this will report: 

· Equipment in the database and not on the drawing, 

· Equipment on the drawing and not in the database, and 

· Equipment where quantities do not match.  

For Rooms where there is a difference the enclosure is highlighted in red.

To view the mismatches for a Room select the ADB>Database>Check Room option and select the Room Enclosure.  Any differences between the drawing and the database will be displayed a separate floating window. The room enclosure will also be highlighted in red if differences exist. 
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The Schedule Comparison Report form can be left open and the differences report refreshed at any time by clicking the differences button  [image: image43.png]Differences



. The Room Component Schedule extracted from the drawing can also be displayed on the same form by selecting the [image: image44.png]Schedule



 button. 

To view the mismatches for all rooms select the ADB>Database>Check Department Rooms option and specify the department code.  Any differences between the drawing and the database will be displayed to the AutoCAD command window – click F2 to expand the window to view all differences. The room enclosures will also be highlighted in red if differences exist.

When a room is loaded from the database the Load Room flag is automatically unset, so that the room is not reloaded.  A room may be reloaded from the database by checking this flag.  The room contents on the drawing should be deleted first.  Additional rooms may be added at any time by adding new enclosures and loaded by the selecting the Activity DataBase Department button [image: image45.png]


 on the Activity DataBase Toolbar or selecting ADB>Insert>Department from the Activity DataBase AutoCAD menu.

Single Room Loading

A single room may be loaded into a drawing using ADB>Insert>Room. The ADB Ribbon equivalent is
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Explode the room and rearrange the equipment. Draw a new enclosure around the room ADB>Enclosure>New. The ADB Ribbon equivalent is
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Ensure that the Load Room option is not checked. If you forget to do this you can use the ADB>Enclosures>Edit form to remove the check-box setting. The ADB>Enclosures>Un-set Load Room facility may be used to uncheck several rooms by selecting the enclosures. 
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The ADB Ribbon Equivalent is
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Updating the ADB project database from the drawing

The ADB project database can be updated from the drawing either by specifying the department or room. Note: this must be done if automated C-Sheets are to be generated.

To update by department select ADB>Save Department… enter the department code to update. The ADB Ribbon equivalent is
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To update a single room from the drawing by select ADB>Save Room>By Enclosure option and select the enclosure. This will save the Room’s contents and the enclosure to the database.  The ADB Ribbon equivalent is
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If the option Update Room Areas from Enclosure is checked, the area of the room will be calculated from the enclosure, displayed on the drawing and written back to the ADB project database.
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Conversion between 2D/3D Graphics

Activity DataBase loads graphics as either 2D or 3D blocks and can switch between either mode using the ADB>Tools>Convert Drawing to 3D and ADB>Tools>Convert Drawing to 2D menu option.  Items are loaded at the correct height specified in the database. The ADB Ribbon Equivalent
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Modifying a Drawing

Individual Rooms, Assemblies and Components can be added to a drawing in two ways.  If the Room, Assembly or Component code is known, select the appropriate button on the Activity DataBase Toolbar. Note this facility is not available for instanced Rooms which should be loaded by defining an enclosure and loading by Department.
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Alternatively you can search for the entity using the ADB>Insert Menu option. The ADB Ribbon equivalent is where “C” indicates insert by code.
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Use columns filters to filter the list
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To insert the Room into the drawing select the required room and click Insert.

Multiple Drawings

More than one drawing may be opened at the same time.  This enables components to be created and modified within one AutoCAD session.

Creating and Modifying Components Graphics

Activity DataBase allows users to create and modify their own components.  This can be achieved in one of two ways, producing 3D models with automatic 2D view generation and individual view creation.

Activity DataBase supports both 3D and 2D component views.  For minimal graphical functionality a 2D plan view is all that need be created.  For automated generation of room elevations, component elevations are required and for full 3D support 3D surface models need to be created.

Once a 3D model has been created Activity DataBase will generate all other views for you.  Each view has particular suffix.


-3
3D


-P
Plan


-E
Front 


-TE
Left Elevation


-SE
Right Elevation


-RE
Rear Elevation

e.g.  CHA017-3, CHA017-P etc.

If you create views manually you will need to create blocks that adhere to this convention.

3D models can consist of 3D lines, circles, arcs, faces and polylines.  2D graphics can be constructed from lines, circles, arcs and polylines.

To create a new 3D component open a new drawing.  The component must exist within the project.  If this is not the case, use the Activity DataBase text system to create a new component.  You can run the Activity DataBase text system from AutoCAD by selecting the Activity DataBase Explorer button on the Activity DataBase AutoCAD toolbar. This option is not available on the ADB Ribbon, in this case run a separate instance of the ADB Explorer.
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To create the component in the text system, proceed as follows:
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Ensure you give the Component a Class and Group and Layer.

Open a new drawing in AutoCAD and draw the component.

Activity DataBase 3D components should be created using AutoCAD surface modelling facilities, available on the standard AutoCAD surfaces menu
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Tools - Generate 2D Views

To generate 2D views automatically from the 3D model AutoCAD, an Activity DataBase specific DXB plotter should be configured as described in the Getting Started Guide.

On selecting the ADB>Tools>Generate 2D Views menu option the screen below is displayed.  The ADB Ribbon equivalent is.
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Check the views you require (you may want a symbolic view for plan) and select OK.  You will see the view change and views created.  
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To save the generated views to the database select ADB->Save>Component enter the code of the component and click OK. The component is then available for insertion into the drawing.
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Creating and Modifying Single Rooms

Single Rooms can be modified from a Room-loaded drawing directly by either selecting the items within the Room or selecting the Room’s enclosure. In previous versions of Activity DataBase single Rooms could only be modified by opening the room using AutoCAD in a similar manner to the Activity DataBase Graphical Editor.  

To update the room by selecting the items load the room into the drawing explode it and add/delete/arrange the items.  To save the Room select ADB>Save>Room>By Selection Set… menu option.   
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The ADB Ribbon equivalent is
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Enter the room code.
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Select the items using any of the AutoCAD standard methods and finally update the ADB project database.
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To update the ADB project database from a loaded Room drawing with Enclosures, select the ADB>Save>Room>By Enclosure menu option and select the Room enclosure.
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The ADB Ribbon equivalent is
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Creating and Modifying Single Assemblies

Single assemblies should be modified by loading them into an AutoCAD drawing, in a similar manner to single rooms.

The assembly must be defined i.e. exist in the project database.  If this is not already the case, create the assembly using the Activity DataBase Explorer.  User defined Assemblies normally start with the letters UA e.g. UA9000. The assembly shown here has been copied from the standard ADB assembly SA1224.
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Insert the assembly into a new drawing using ADB>Insert>Assembly...

The ADB Ribbon equivalent is
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By default the Assembly is loaded in 2D; if you wish to work in 3D, select ADB>Tools>Convert to 3D.  The ADB Ribbon equivalent is 
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If you are generating C-Sheets you need to ensure that the items are elevated to the correct Z position.
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Arrange the items as required and select the ADB->Save Assembly menu option.  
The ADB Ribbon equivalent is
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Enter the code of the assembly so this can be verified in the database.
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Select the items which make-up the assembly, specify the base point and click Yes on the form below to write the assembly definition to the database.
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Automatic Creation of Elevations – C-Sheets

A C-Sheet consists of a plan with elevations of each wall, a 3D view and a component schedule.

C-Sheets can now be generated by Department as well as by Project.

To produce a C-Sheet, an enclosure must have been created and saved to the database.  This can be done either by saving the Department or by saving a single Room as described above.  To generate one or more C-Sheets, open the Activity DataBase Explorer and navigate to the required Room.  Select the ADB>Tools>C-Sheets-Fold Out Views… and select the Rooms for which the C-Sheets are required.  This will produce the C-Sheets automatically.  Two variants are available, fold-out or inline elevations. 
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The ADB Ribbon equivalent is
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The C-Sheet plan can optionally be a clipped XRef from the main GA. Please ensure this drawing is saved before generating the C-Sheets.
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Elevations contain labels and scales
The Schedule displayed on the C-Sheet can be a component schedule or a nested schedule (a schedule displaying the assemblies, sub-assemblies components etc. )

	
[image: image96.png]save

Insert [Mlsviaver -

Endosures = =

Datobase. Messur
Byayer e

Spacebores

Enclosures

Comporent View Level
Compornent View Level 2
Compornent View Level 3

Create Components in 3D
Use External Graphics

Redefine Graphics on Insertion

Display Code Attrbute
Set Attrbute Font Height
Set Attribute Fort Rotation
Top Level Atrbutes

Update Room Areas from Enclosure.

Set Elevation Depth
et schedue Font Height

Set C-Shest Eslevation Offset
Set C-Sheet Folder

Ref Plan on C-Sheet.






Please Note: C-Sheet drawings are closed after they are generated and saved to the c:\Program Files\DHEFD\Activity Database\Work directory. This can be changed by selecting Set C-Sheet Folder
[image: image97.png]c-Sheet folder - Tutorial1e loaded.dwg

Speciy the C:Shest folder. _ Ciick to change path
[CAADBCSheets





Elevation Depth, Schedule Font Height and Elevation Offset can also be specified using the ADB>Options menu.

The ADB Ribbon Equivalents are
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Instanced Data

The ADB AutoCAD interface also supports instanced data. In the sample drawing Rooms G.01 and G.03 have the same code B0308 and must therefore be identical. If only one room is required to have CHA900 an instance of the room is required. The rooms could be save using the ADB Explorer to a new code e.g. B0308A alternatively an instance can be automatically created by editing the enclosure.
Select ADB>Enclosures>Edit. Clicking  [image: image99.png]


 creates a copy of the Room with a unique code for the project while retaining a link to the base Room. Instancing can be reversed by clicking [image: image100.png]
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The ADB Ribbon equivalent is
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External Component Graphics

The ADB AutoCAD interface supports external component graphics e.g. manufacturers drawings and solid models. If this option is selected and a drawing file placed in AutoCAD support path this will be loaded in preference to the graphic held in the database. These files should be named according to the normal ADB convention e.g. CHA017-3.dwg for 3D models, CHA017-P.dwg for plans etc.
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The ADB Ribbon equivalent is
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Scheduling 

Schedules should be generated from the ADB project database using the standard ADB reports after the database has been updated from the drawing.

Audit

If Auditing is turned-on additions, deleted and changes in quantity made on the drawing since a specified date can be displayed on the room component schedule
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Other Drawing Utilities and Options

Tools-Update Component Views rebuilds the component blocks from the database.  This is useful where a component graphic has been modified and needs to be updated on the drawing.

Tools-Update Create Elevation for Single Wall allows the generation of an elevation of one or more Rooms by specifying the left and right-hand ends of the wall and selecting the contents Rooms.  Any items further than the Elevation Depth setting form the wall will be automatically excluded from the elevation.

Tools-Set Attributes Constant.  The Code of every Assembly and Component is defined as an attribute.  More attributes will become visible as the blocks are exploded.  These attributes are in-fact attribute definitions that will not be visible if the Activity DataBase items are held as Xrefs.  Setting the attribute definitions constant will make them visible when held as Xrefs.  

Options-Update Room Area from Enclosure.  When this option is specified, if a Department or Room is saved to the database, the Room area will be calculated from the enclosure, indicated on the drawing and the Room Area field updated in the database.

Options-Redefine Graphics on Insertion. Set this option when modifications have been made to the graphics in the database and the drawining contains the old block definition.

AutoCAD 2007/8/9/10/11/12 Considerations

AutoCAD 2007/8/9/10 have more than one mode e.g. 3D Modelling and AutoCAD Classic. If you switch modes within an AutoCAD session the ADB menu and toolbar will be removed. To retain the ADB menu and toolbar save the current Workspace Settings to a workspace named ADB. This can be recalled at any time.
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For AutoCAD 2009 you should switch to AutoCAD Classic view so the traditional menu is displayed.

For AutoCAD 2010/11/12 32 bit versions you should ensure the menu is displayed by using setting MENUBAR variable to 1.
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